const regex = /(<a\s[^>]*>[^<]*<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a\\s[^>]*>[^<]*<\\\/a>)', 'gm')
const str = `If you <a href='https://example.com'>Click here</a> then <a href='https://example.net'>Click here</a>.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}