#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(MORE)|LESS) THAN CAD [\d,]+(?(1)(?: BUT LESS THAN CAD [\d,]+)?)$"
Local $sString = "MORE THAN CAD 10,000" & @CRLF & _
"MORE THAN CAD 10,000 BUT LESS THAN CAD 15,000" & @CRLF & _
"LESS THAN CAD 10,000" & @CRLF & _
"MORE THAN CAD 10,000LESS THAN CAD 15,000" & @CRLF & _
"LESS THAN CAD 10,000 BUT LESS THAN CAD 10,000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")