import re
regex = re.compile(r"^(?:(MORE)|LESS) THAN CAD [\d,]+(?(1)(?: BUT LESS THAN CAD [\d,]+)?)$", flags=re.MULTILINE)
test_str = ("MORE THAN CAD 10,000\n"
"MORE THAN CAD 10,000 BUT LESS THAN CAD 15,000\n"
"LESS THAN CAD 10,000\n"
"MORE THAN CAD 10,000LESS THAN CAD 15,000\n"
"LESS THAN CAD 10,000 BUT LESS THAN CAD 10,000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")