import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(MORE)|LESS) THAN CAD [\\d,]+(?(1)(?: BUT LESS THAN CAD [\\d,]+)?)$";
final String string = "MORE THAN CAD 10,000\n"
+ "MORE THAN CAD 10,000 BUT LESS THAN CAD 15,000\n"
+ "LESS THAN CAD 10,000\n"
+ "MORE THAN CAD 10,000LESS THAN CAD 15,000\n"
+ "LESS THAN CAD 10,000 BUT LESS THAN CAD 10,000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}