#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\K\bONE\b.*"
Local $sString = "ONE;TWO;THREE;ONE;FOUR;FIVE " & @CRLF & _
"2 TEST " & @CRLF & _
"3 ONE test" & @CRLF & _
"4 TEST " & @CRLF & _
"5 TEST " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")