re = /^.*\K\bONE\b.*/m
str = 'ONE;TWO;THREE;ONE;FOUR;FIVE
2 TEST
3 ONE test
4 TEST
5 TEST
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end