using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\K\bONE\b.*";
string input = @"ONE;TWO;THREE;ONE;FOUR;FIVE
2 TEST
3 ONE test
4 TEST
5 TEST
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}