import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.+[@#$%&*-_\\/\\.!])(?=.+[a-z])(?=.+[A-Z])(?=.+[0-9])[A-Za-z0-9@#$%&*-_\\/\\.!]{6,30}$";
final String string = "A08a^&0azAad\n"
+ "A08a^&0azAadA08a^&0azAadA08a^&0azAad\n"
+ "ad98qrq\n"
+ "Afaq-r9Â\n"
+ "Afaq-r9z&8\n"
+ "Afaqr9z&8A\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}