$re = '/^(?=.+[@#$%&*-_\/\.!])(?=.+[a-z])(?=.+[A-Z])(?=.+[0-9])[A-Za-z0-9@#$%&*-_\/\.!]{6,30}$/m';
$str = 'A08a^&0azAad
A08a^&0azAadA08a^&0azAadA08a^&0azAad
ad98qrq
Afaq-r9Â
Afaq-r9z&8
Afaqr9z&8A
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);