re = /^(?=.+[@#$%&*-_\/\.!])(?=.+[a-z])(?=.+[A-Z])(?=.+[0-9])[A-Za-z0-9@#$%&*-_\/\.!]{6,30}$/m
str = 'A08a^&0azAad
A08a^&0azAadA08a^&0azAadA08a^&0azAad
ad98qrq
Afaq-r9Â
Afaq-r9z&8
Afaqr9z&8A
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end