import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[(\\b(?i)sale\\b|\\b(?i)wtb\\b|\\b(?i)trade\\b|\\b(?i)go\\b|\\b(?i)iso\\b)\\].+\\[[A-Z][A-Z]\\].+\\[.+\\].+\\[.+\\])|(\\[(\\b(?i)sale\\b|\\b(?i)wtb\\b|\\b(?i)trade\\b|\\b(?i)go\\b|\\b(?i)iso\\b)\\]\\[[A-Z][A-Z]\\]\\[.+\\]\\[.+\\])";
final String string = "[sale][US][€12][sd]\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}