re = /(\[(\b(?i)sale\b|\b(?i)wtb\b|\b(?i)trade\b|\b(?i)go\b|\b(?i)iso\b)\].+\[[A-Z][A-Z]\].+\[.+\].+\[.+\])|(\[(\b(?i)sale\b|\b(?i)wtb\b|\b(?i)trade\b|\b(?i)go\b|\b(?i)iso\b)\]\[[A-Z][A-Z]\]\[.+\]\[.+\])/m
str = '[sale][US][€12][sd]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end