// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[(\b(?i)sale\b|\b(?i)wtb\b|\b(?i)trade\b|\b(?i)go\b|\b(?i)iso\b)\].+\[[A-Z][A-Z]\].+\[.+\].+\[.+\])|(\[(\b(?i)sale\b|\b(?i)wtb\b|\b(?i)trade\b|\b(?i)go\b|\b(?i)iso\b)\]\[[A-Z][A-Z]\]\[.+\]\[.+\])").unwrap();
let string = "[sale][US][€12][sd]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}