using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Ordernr.*[\r\n]+(.*)";
string input = @"21Sid1
Ordernr Skip everything upto new line
E17222
By
Seller";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}