$re = '/Ordernr.*[\r\n]+(.*)/';
$str = '21Sid1
Ordernr Skip everything upto new line
E17222
By
Seller';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);