#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[\?\][^[%]*+(?:\[(?!\?])[^[%]*|%(?!empty%)[^[{%]*)*+%empty%[^[]*+(?:\[(?!/?\?])[^[]*)*+\[/\?]"
Local $sString = "[?]<h1>%empty%</h1>" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] " & @CRLF & _
"text " & @CRLF & _
"[?]<h1>%empty%</h1>" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] " & @CRLF & _
"text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[?]<h1>%!empty%</h1>" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] " & @CRLF & _
"text " & @CRLF & _
"[?][][/<h1>%empty%</h1>][][[[]]]" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] " & @CRLF & _
"[?]<h1>%empty%</h1>" & @CRLF & _
"<p>text</p>[?]" & @CRLF & _
"[/?] " & @CRLF & _
"text[?]<h1>%!empty%</h1>" & @CRLF & _
"<p>text</p>" & @CRLF & _
"[/?] "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")