$re = '~\[\?\][^[%]*+(?:\[(?!\?])[^[%]*|%(?!empty%)[^[{%]*)*+%empty%[^[]*+(?:\[(?!/?\?])[^[]*)*+\[/\?]~m';
$str = '[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%!empty%</h1>
<p>text</p>
[/?]
text
[?][][/<h1>%empty%</h1>][][[[]]]
<p>text</p>
[/?]
[?]<h1>%empty%</h1>
<p>text</p>[?]
[/?]
text[?]<h1>%!empty%</h1>
<p>text</p>
[/?] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);