import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\?\\][^[%]*+(?:\\[(?!\\?])[^[%]*|%(?!empty%)[^[\\{%]*)*+%empty%[^[]*+(?:\\[(?!/?\\?])[^[]*)*+\\[/\\?]";
final String string = "[?]<h1>%empty%</h1>\n"
+ "<p>text</p>\n"
+ "[/?] \n"
+ "text \n"
+ "[?]<h1>%empty%</h1>\n"
+ "<p>text</p>\n"
+ "[/?] \n"
+ "text\n\n\n\n"
+ "[?]<h1>%!empty%</h1>\n"
+ "<p>text</p>\n"
+ "[/?] \n"
+ "text \n"
+ "[?][][/<h1>%empty%</h1>][][[[]]]\n"
+ "<p>text</p>\n"
+ "[/?] \n"
+ "[?]<h1>%empty%</h1>\n"
+ "<p>text</p>[?]\n"
+ "[/?] \n"
+ "text[?]<h1>%!empty%</h1>\n"
+ "<p>text</p>\n"
+ "[/?] ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}