const regex = new RegExp('\\[\\?\\][^[%]*+(?:\\[(?!\\?])[^[%]*|%(?!empty%)[^[{%]*)*+%empty%[^[]*+(?:\\[(?!/?\\?])[^[]*)*+\\[/\\?]', 'gm')
const str = `[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%!empty%</h1>
<p>text</p>
[/?]
text
[?][][/<h1>%empty%</h1>][][[[]]]
<p>text</p>
[/?]
[?]<h1>%empty%</h1>
<p>text</p>[?]
[/?]
text[?]<h1>%!empty%</h1>
<p>text</p>
[/?] `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}