#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<div class="article">(.*?)<\/div>"
Local $sString = "<div class="article">" & @CRLF & _
" <p class="title">Test!</p>" & @CRLF & _
" <div>Content content</div>" & @CRLF & _
" <p>test test</p>" & @CRLF & _
" <div class="test">test</div>" & @CRLF & _
" <p>test</p>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div class="article">" & @CRLF & _
" <p class="title">Test1!</p>" & @CRLF & _
" <div>Content content1</div>" & @CRLF & _
" <p>test test1</p>" & @CRLF & _
" <div class="test">test1</div>" & @CRLF & _
" <p>test1</p>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")