// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<div class="article">(.*?)<\/div>"#).unwrap();
let string = "<div class=\"article\">
<p class=\"title\">Test!</p>
<div>Content content</div>
<p>test test</p>
<div class=\"test\">test</div>
<p>test</p>
</div>
<div class=\"article\">
<p class=\"title\">Test1!</p>
<div>Content content1</div>
<p>test test1</p>
<div class=\"test\">test1</div>
<p>test1</p>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}