use strict;
my $str = '<div class="article">
<p class="title">Test!</p>
<div>Content content</div>
<p>test test</p>
<div class="test">test</div>
<p>test</p>
</div>
<div class="article">
<p class="title">Test1!</p>
<div>Content content1</div>
<p>test test1</p>
<div class="test">test1</div>
<p>test1</p>
</div>';
my $regex = qr/<div class="article">(.*?)<\/div>/isp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}