using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""article"">(.*?)<\/div>";
string input = @"<div class=""article"">
<p class=""title"">Test!</p>
<div>Content content</div>
<p>test test</p>
<div class=""test"">test</div>
<p>test</p>
</div>
<div class=""article"">
<p class=""title"">Test1!</p>
<div>Content content1</div>
<p>test test1</p>
<div class=""test"">test1</div>
<p>test1</p>
</div>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}