using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?<_KEY_>[^:]+):(?<_VAL_>.*)[\r\n]";
string input = @" Name: HD Front Driveway
IP: 0.0.0.0
ID: 11
Mac: D4:21:22:C9:B4:62
FW Ver: 3.0.02.51
Manufacturer: iControl
Model: iCamera2-C
Video Size: LARGE
Verified: true
RSSI: dB
Supported Video Formats: [MJPEG, FLV, RTSP]
Supported Video Codecs: [H264, MPEG4]
FLV URL:
MJPEG URL:
API Version: 3.3
MotionTurnedOn: true
MotionSensitivy: 1 (LOW)
Local Video Aspect Ratio: 16:9
Local Video Resolution: 1280:720
Remote Video Aspect Ratio: 16:9
Remote Video Resolution: 1280:720";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}