import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?<_KEY_>[^:]+):(?<_VAL_>.*)[\\r\\n]";
final String string = " Name: HD Front Driveway\n"
+ " IP: 0.0.0.0\n"
+ " ID: 11\n"
+ " Mac: D4:21:22:C9:B4:62\n"
+ " FW Ver: 3.0.02.51\n"
+ " Manufacturer: iControl\n"
+ " Model: iCamera2-C\n"
+ " Video Size: LARGE\n"
+ " Verified: true\n"
+ " RSSI: dB\n"
+ " Supported Video Formats: [MJPEG, FLV, RTSP]\n"
+ " Supported Video Codecs: [H264, MPEG4]\n"
+ " FLV URL:\n"
+ " MJPEG URL:\n"
+ " API Version: 3.3\n"
+ " MotionTurnedOn: true\n"
+ " MotionSensitivy: 1 (LOW)\n"
+ " Local Video Aspect Ratio: 16:9\n"
+ " Local Video Resolution: 1280:720\n"
+ " Remote Video Aspect Ratio: 16:9\n"
+ " Remote Video Resolution: 1280:720";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}