use strict;
my $str = ' Name: HD Front Driveway
IP: 0.0.0.0
ID: 11
Mac: D4:21:22:C9:B4:62
FW Ver: 3.0.02.51
Manufacturer: iControl
Model: iCamera2-C
Video Size: LARGE
Verified: true
RSSI: dB
Supported Video Formats: [MJPEG, FLV, RTSP]
Supported Video Codecs: [H264, MPEG4]
FLV URL:
MJPEG URL:
API Version: 3.3
MotionTurnedOn: true
MotionSensitivy: 1 (LOW)
Local Video Aspect Ratio: 16:9
Local Video Resolution: 1280:720
Remote Video Aspect Ratio: 16:9
Remote Video Resolution: 1280:720';
my $regex = qr/\s*(?<_KEY_>[^:]+):(?<_VAL_>.*)[\r\n]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}