package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?<_KEY_>[^:]+):(?<_VAL_>.*)[\r\n]`)
var str = ` Name: HD Front Driveway
IP: 0.0.0.0
ID: 11
Mac: D4:21:22:C9:B4:62
FW Ver: 3.0.02.51
Manufacturer: iControl
Model: iCamera2-C
Video Size: LARGE
Verified: true
RSSI: dB
Supported Video Formats: [MJPEG, FLV, RTSP]
Supported Video Codecs: [H264, MPEG4]
FLV URL:
MJPEG URL:
API Version: 3.3
MotionTurnedOn: true
MotionSensitivy: 1 (LOW)
Local Video Aspect Ratio: 16:9
Local Video Resolution: 1280:720
Remote Video Aspect Ratio: 16:9
Remote Video Resolution: 1280:720`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}