#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=SUMME|Gesamtsumme|Brutto|Gesamtbetrag|Endsumme|Rechnungsbetrag)(:)*([\s]*|(EUR|€))*(((\d{1,3}(,|.))*\d{2}))([\s]|€)*"
Local $sString = "SUMME EUR 9,50" & @CRLF & _
"SUMME1.332,80 €Sie haben noch Fragen? Sie erreichen uns tglch von XXXX bis XXX unter (#49) 1234108 78 54"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")