use strict;
my $str = 'SUMME EUR 9,50
SUMME1.332,80 €Sie haben noch Fragen? Sie erreichen uns tglch von XXXX bis XXX unter (#49) 1234108 78 54';
my $regex = qr/(?<=SUMME|Gesamtsumme|Brutto|Gesamtbetrag|Endsumme|Rechnungsbetrag)(:)*([\s]*|(EUR|€))*(((\d{1,3}(,|.))*\d{2}))([\s]|€)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}