import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=SUMME|Gesamtsumme|Brutto|Gesamtbetrag|Endsumme|Rechnungsbetrag)(:)*([\\s]*|(EUR|€))*(((\\d{1,3}(,|.))*\\d{2}))([\\s]|€)*";
final String string = "SUMME EUR 9,50\n"
+ "SUMME1.332,80 €Sie haben noch Fragen? Sie erreichen uns tglch von XXXX bis XXX unter (#49) 1234108 78 54";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}