re = /(?<=SUMME|Gesamtsumme|Brutto|Gesamtbetrag|Endsumme|Rechnungsbetrag)(:)*([\s]*|(EUR|€))*(((\d{1,3}(,|.))*\d{2}))([\s]|€)*/m
str = 'SUMME EUR 9,50
SUMME1.332,80 €Sie haben noch Fragen? Sie erreichen uns tglch von XXXX bis XXX unter (#49) 1234108 78 54'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end