#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^For:\s.*?\b(?<first_ip>\d{1,3}(?:\.\d{1,3}){3})"
Local $sString = "For: ${jnd:ldap://${namingDetails}.for.net.sh}, 4.5.3.2, 23.200.06.110 V-" & @CRLF & _
"For: 10.10.21.17, 5.18.11.74, 23.36.3.22 V-" & @CRLF & _
"For: 23.3.39.1, 21.61.39.21 V-" & @CRLF & _
"For: 3.3.39.1 V-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")