package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^For:\s.*?\b(?<first_ip>\d{1,3}(?:\.\d{1,3}){3})`)
var str = `For: ${jnd:ldap://${namingDetails}.for.net.sh}, 4.5.3.2, 23.200.06.110 V-
For: 10.10.21.17, 5.18.11.74, 23.36.3.22 V-
For: 23.3.39.1, 21.61.39.21 V-
For: 3.3.39.1 V-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}