using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^For:\s.*?\b(?<first_ip>\d{1,3}(?:\.\d{1,3}){3})";
string input = @"For: ${jnd:ldap://${namingDetails}.for.net.sh}, 4.5.3.2, 23.200.06.110 V-
For: 10.10.21.17, 5.18.11.74, 23.36.3.22 V-
For: 23.3.39.1, 21.61.39.21 V-
For: 3.3.39.1 V-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}