const regex = /^For:\s.*?\b(?<first_ip>\d{1,3}(?:\.\d{1,3}){3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^For:\\s.*?\\b(?<first_ip>\\d{1,3}(?:\\.\\d{1,3}){3})', 'gm')
const str = `For: \${jnd:ldap://\${namingDetails}.for.net.sh}, 4.5.3.2, 23.200.06.110 V-
For: 10.10.21.17, 5.18.11.74, 23.36.3.22 V-
For: 23.3.39.1, 21.61.39.21 V-
For: 3.3.39.1 V-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}