#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^three-dxf-master\/[^\/]*\/?$"
Local $sString = "three-dxf-master/" & @CRLF & _
"three-dxf-master/.DS_Store" & @CRLF & _
"three-dxf-master/.gitignore" & @CRLF & _
"three-dxf-master/LICENSE" & @CRLF & _
"three-dxf-master/README.md" & @CRLF & _
"three-dxf-master/bower.json" & @CRLF & _
"three-dxf-master/bower_components/" & @CRLF & _
"three-dxf-master/bower_components/foo" & @CRLF & _
"three-dxf-master/bower_components/bar/" & @CRLF & _
"www/" & @CRLF & _
"www/xxx" & @CRLF & _
"www/yyy/" & @CRLF & _
"www/yyy/zzz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")