using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^three-dxf-master\/[^\/]*\/?$";
string input = @"three-dxf-master/
three-dxf-master/.DS_Store
three-dxf-master/.gitignore
three-dxf-master/LICENSE
three-dxf-master/README.md
three-dxf-master/bower.json
three-dxf-master/bower_components/
three-dxf-master/bower_components/foo
three-dxf-master/bower_components/bar/
www/
www/xxx
www/yyy/
www/yyy/zzz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}