package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^three-dxf-master\/[^\/]*\/?$`)
var str = `three-dxf-master/
three-dxf-master/.DS_Store
three-dxf-master/.gitignore
three-dxf-master/LICENSE
three-dxf-master/README.md
three-dxf-master/bower.json
three-dxf-master/bower_components/
three-dxf-master/bower_components/foo
three-dxf-master/bower_components/bar/
www/
www/xxx
www/yyy/
www/yyy/zzz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}