re = /^three-dxf-master\/[^\/]*\/?$/m
str = 'three-dxf-master/
three-dxf-master/.DS_Store
three-dxf-master/.gitignore
three-dxf-master/LICENSE
three-dxf-master/README.md
three-dxf-master/bower.json
three-dxf-master/bower_components/
three-dxf-master/bower_components/foo
three-dxf-master/bower_components/bar/
www/
www/xxx
www/yyy/
www/yyy/zzz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end