using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+) (.+) \[(.+)\] - (.+)";
string input = @"(17-03-2015 15:00:00) pbphl0w [niels] - (testing) dit is een bericht
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}