$re = '/(.+) (.+) \[(.+)\] - (.+)/';
$str = '(17-03-2015 15:00:00) pbphl0w [niels] - (testing) dit is een bericht
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);