re = /(.+) (.+) \[(.+)\] - (.+)/
str = '(17-03-2015 15:00:00) pbphl0w [niels] - (testing) dit is een bericht
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end