using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div(>|[\s\n]*[^>]*>)((.|\n)(?!<\/div[\s\n]*>)(?!<div(>|[\s\n]*[^>]*>)))*world((.|\n)(?!<\/div[\s\n]*>))*.?<\/div[\s\n]*>";
string input = @"<div>hello-world-hello</div>
<div id=""test"">
hello world hello
</div>
<div>no match</div>
<div
>
hello
world
hello
</div
>
<div>
<div>
<div>
If ""world"" is inside the innermost div, only the innermost div will be captured.
</div>
</div>
</div>
<div>
<div>
If ""world"" is outside the innermost div, the captured text will end at the wrong end div tag.
<div>
</div>
</div>
</div>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}