re = /<div(>|[\s\n]*[^>]*>)((.|\n)(?!<\/div[\s\n]*>)(?!<div(>|[\s\n]*[^>]*>)))*world((.|\n)(?!<\/div[\s\n]*>))*.?<\/div[\s\n]*>/m
str = '<div>hello-world-hello</div>
<div id="test">
hello world hello
</div>
<div>no match</div>
<div
>
hello
world
hello
</div
>
<div>
<div>
<div>
If "world" is inside the innermost div, only the innermost div will be captured.
</div>
</div>
</div>
<div>
<div>
If "world" is outside the innermost div, the captured text will end at the wrong end div tag.
<div>
</div>
</div>
</div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end