import Foundation
let pattern = #"<div(>|[\s\n]*[^>]*>)((.|\n)(?!<\/div[\s\n]*>)(?!<div(>|[\s\n]*[^>]*>)))*world((.|\n)(?!<\/div[\s\n]*>))*.?<\/div[\s\n]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<div>hello-world-hello</div>
<div id="test">
hello world hello
</div>
<div>no match</div>
<div
>
hello
world
hello
</div
>
<div>
<div>
<div>
If "world" is inside the innermost div, only the innermost div will be captured.
</div>
</div>
</div>
<div>
<div>
If "world" is outside the innermost div, the captured text will end at the wrong end div tag.
<div>
</div>
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)