const regex = /<div(>|[\s\n]*[^>]*>)((.|\n)(?!<\/div[\s\n]*>)(?!<div(>|[\s\n]*[^>]*>)))*world((.|\n)(?!<\/div[\s\n]*>))*.?<\/div[\s\n]*>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div(>|[\\s\\n]*[^>]*>)((.|\\n)(?!<\\\/div[\\s\\n]*>)(?!<div(>|[\\s\\n]*[^>]*>)))*world((.|\\n)(?!<\\\/div[\\s\\n]*>))*.?<\\\/div[\\s\\n]*>', 'gms')
const str = `<div>hello-world-hello</div>
<div id="test">
hello world hello
</div>
<div>no match</div>
<div
>
hello
world
hello
</div
>
<div>
<div>
<div>
If "world" is inside the innermost div, only the innermost div will be captured.
</div>
</div>
</div>
<div>
<div>
If "world" is outside the innermost div, the captured text will end at the wrong end div tag.
<div>
</div>
</div>
</div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}