# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/.+>|<.+>)[\s]+(<)/$1$2/g;t' <<< "<note>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>"