package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<\/.+>|<.+>)[\s]+(<)`)
var str = `<note>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}