import Foundation
let pattern = #"(<\/.+>|<.+>)[\s]+(<)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<note>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)