using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(score.*\d\d|score.*\d)";
string input = @"games >= 2 AND score between 1 and 10 and Pais = 2
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}